Kubuntu 6.10 Edgy Eft

30 ottobre 2006

Vista la disponibilità di Kubuntu 6.10 (dal 26 ottobre), ho deciso di scaricarla ed installarla sul mio iMac con Parallels: come per Windows XP ho creato una macchina virtuale con 512MB di Ram e 8Gb di disco.

Prima considerazione: la decisione di Ubuntu di eliminare l’installer tradizionale e trasformare il cd di installazione in un live-cd è interessante e comoda, peccato che rallenti in maniera considerevole i tempi di avvio.

installazione.png

Finita l’installazione, ecco sorgere i primi problemi:

  • l’interfaccia è in inglese, non c’è traccia dell’italiano
  • la risoluzione massima disponibile è 1024×768

Veniamo alle soluzioni (si suppone che la macchina virtuale sia correttamente connessa ad Internet).

Impostare l’italiano

  • Andare nel menu KDE->System->Language support
  • Selezionare Italian nell’elenco, verranno scaricati e installati i relativi pacchetti

Nel mio caso l’operazione si è interrotta ed ho dovuto dare un sudo dpkg --configure -a per sbloccare il database.

Aumentare la risoluzione massima

Per prima cosa bisogna agire a livello di Parallels (naturalmente la macchina virtuale deve essere ferma):

  • selezionare la macchina virtuale, fare clic sul pulsante EDIT
  • nella sezione VIDEO verificare che sia attivo il flag su “Enable custom screen resolution” e aggiungere la risoluzione desiderata: nel mio caso 1200×960
  • salvare le modifiche e avviare Kubuntu

A questo punto da terminale digitare sudo dpkg-reconfigure xserver-xorg e aggiungere 1280×960 alle risoluzioni disponibili.

Conclusioni

L’unico problema rimasto è la chiusura: lo shut-down non avviene completamente e bisogna bloccare manualmente la macchina virtuale (con relativo avviso di possibile perdita di dati). Su questo punto non ho ancora trovato una soluzione (solo conferme) 🙁

Tag Technorati: ,

24 commenti/trackback a “Kubuntu 6.10 Edgy Eft”

  1. Andrea scrive:

    Ciao,
    per l’italiano: Crealabs, una società di Torino, ha ottenuto dalla Canonical Ltd l’autorizzazione a distribuire una versione di *buntu contenente anche i pacchetti in lingua italiana.

    Andrea.

  2. Underpass scrive:

    Ciao Pseudotecnico,

    1) Per Kubuntu come per Ubuntu esiste anche la versione ISO “alternate” che utilizza un’installer testuale e che non può essere usata come Live CD: sicuramente il processo di installazione è più veloce e probabilmente più “pilotabile”.

    2) Per il problema dello shutdown, hai provato ad escludere servizi come ad esempio l’ACPI? Il system log ti riporta qualche errore?

    3) Come già ti ho detto: perché non una bella Debian con KDE e ti passa la paura? 😀

  3. dalco scrive:

    Non avevo mai pensato al problema della risoluzione video: con Vmware la risoluzione del sistema ospite cambia al volo quando si ridimensiona la finestra della macchina virtuale.

    Per la lingua con la dapper avevo scaricato preventivamente le traduzioni con il metapacchetto per l’italiano da Adept e poi ho proceduto con l’impostazione in kde.

    Non hai nessun indizio sullo shutdown? Provato a premere esc per togliere lo splash screen? Su che servizio si inceppa?

    Prova, come suggerito da Under, a disattivare l’ACPI (tanto dentro la macchina virtuale non ti serve) aggiungendo “noacpi” ai parametri di boot del kernel (lo si fa al volo appena il sistema si avvia -in grub, il bootloader-: quanto ti fa scegliere in che modalità avviare. Non ricordo cosa di deve premere in *buntu. Nella suse 10 era F2, nella 10.1 lo si può fare direttamente (basta digitarlo).

  4. flod scrive:

    Purtroppo non ho ancora avuto tempo di fare le prove (tra le altre cose sto litigando con la patente della moto e sono decisamente fuori dai gangheri :x)

    Un paio di risposte veloci:
    * il problema della risoluzione l’ho avuto solo con Kubuntu, con la VM di Windows XP nessun problema: aumentando la risoluzione la finestra si adatta, con Kubuntu non riuscivo ad andare oltre al 1024×768
    * Parallels non supporta ACPI
    * non vedo segnalazioni di errore a video: semplicemente sparisce la schermata di KDE, la finestra di Parallels si ridimensiona, diventa tutta nera e stop.

    In ogni caso farò qualche prova ulteriore (se mi passa l’inca$$atura) 😉

  5. flod scrive:

    Disabilitato acpi con il parametro acpi=off nella riga di boot in grub, nessun miglioramento.

    Se provo a fare il login da console e fare lo shutdown, mi dice che il sistema è bloccato (System Halted) ma la finestra di Parallels rimane lì impallata sul nero (posso arrestare o riavviare la VM).

  6. flod scrive:

    Questo è il contenuto di var/log/messages quando richiedo l’halt del sistema

    Oct 30 20:12:12 kubuntu kernel: [ 1858.026805] NET: Registered protocol family 31
    Oct 30 20:12:12 kubuntu kernel: [ 1858.026807] Bluetooth: HCI device and connection manager initialized
    Oct 30 20:12:12 kubuntu kernel: [ 1858.026820] Bluetooth: HCI socket layer initialized
    Oct 30 20:12:12 kubuntu kernel: [ 1858.065091] Bluetooth: L2CAP ver 2.8
    Oct 30 20:12:12 kubuntu kernel: [ 1858.065096] Bluetooth: L2CAP socket layer initialized
    Oct 30 20:12:12 kubuntu kernel: [ 1858.099333] Bluetooth: RFCOMM socket layer initialized
    Oct 30 20:12:12 kubuntu kernel: [ 1858.099347] Bluetooth: RFCOMM TTY layer initialized
    Oct 30 20:12:12 kubuntu kernel: [ 1858.099349] Bluetooth: RFCOMM ver 1.7
    Oct 30 20:16:31 kubuntu exiting on signal 15

  7. Underpass scrive:

    Scarica con adept il pacchetto BUM (Boot Up Manager) e prova a disattivare il gestore del Bluetooth… (E’ un portatile? Ti serve questo Bluetooth? 😕 )

  8. flod scrive:

    Non credo che il problema sia il bluetooth (guarda i minuti che passano tra le due ultime operazioni) 😕
    Se insisti comunque provo 😉

  9. dalco scrive:

    Guarda che system halted non significa sistema bloccato, ma sistema fermato! (Non per niente il -h che si aggiunge al comando shutdown da console significa proprio “halt”).

    È il messaggio standard di linux per dire che la macchina è ferma e la puoi spegnere, quindi non c’è nula che non va! Se acpi non funziona/non è supportato è normale che la macchina non si spenga al termine dello shutdown. La cosa strana piuttosto è che con X attivo non ti faccia vedere nulla.

  10. dalco scrive:

    Ah, nei messaggi del kernel (bluetooth) non c’è nulla che non va, quindi ignorali. Se vuoi vedere veramente cosa succede da una console lancia il comando:

    $ tail -f /var/log/messages

    quindi in un altra console (la puoi aprire con ALT+F2/F3… Ecc.) lancia il comando:

    $ shutdown -h now

    e torna al volo alla console di log precedente (dovrebbe essere ALT+F1, fai prima qualche prova).

    Naturalmente fai tutto ciò dopo aver chiuso X (da X le console sono raggiungibiki con CTRL+ALT+F*)

  11. Underpass scrive:

    Per la serie “l’importante è partecipare” 😀

    Non avevo visto l’ora dell’ultimo messaggio e pensavo che si fosse incartato nello scaricare quei driver…

    Ciao 😉

  12. neon scrive:

    Io posso confermare che *buntu non rileva le risoluzioni disponibili, non dipende da parallels. 2 installazioni su 2 ho dovuto riconfigurare a mano xorg.conf ed anche un mio colega ha avuto lo stesso problema.

  13. kOoLiNuS scrive:

    io cmq ribadisco il concetto:

    non avrai altro cd di ubuntu che l’ ALTERNATE

    😉

    poi aggiungo una cosa: di sta Ubuntu 6.10 leggo _solo_ lamentele, ma c’e’ qualcuno a cui è andata su senza creare problemi ? mah !

  14. flod scrive:

    Se acpi non funziona/non è supportato è normale che la macchina non si spenga al termine dello shutdown.

    Siamo d’accordo, però non si capisce perché quando termino XP il controllo ritorni normalmente a Parallels e non rimanga lì impallato sullo schermo nero 😕

    Se vuoi vedere veramente cosa succede da una console …

    Il log riportato sopra è fatto in maniera analoga: ho fatto lo shutdown , ho riavviato la macchina e controllato il log nell’ora in cui è avvenuto lo shutdown.

    Ora ho fatto come dici: nella prima schermata vedo solo “The system is going down to halt NOW”, nessuna riga aggiunta al log.

    Sul secondo terminale (quello dove ho lanciato il comando) leggo
    The system is going down for halt NOW!
    [ 1172.169521] System halted.

    Poi se ne sta lì impallato finché non blocchi o riavvii la VM 🙁

  15. dalco scrive:

    Penso che sia perché XP al termine dello shutdown manda comunque un segnale APM (pre ACPI) che parallels sa gestire, mentre linux non lo fa.

    Una domanda: parallels non ti gestisce in automatico l’ibernazione delle macchine virtuali, anche se il sistema ospite non è configurato per farlo? Sempre con vmware quando chiudi una VM in automatico la congela, quindi non c’è necessità di fare il boot tutte le volte.

  16. flod scrive:

    Sul discorso ibernazione non ho ancora fatto nessuna prova, dovrò indagare 😉

    Siccome le uso raramente e solo per pochi minuti, di solito preferisco chiuderle e stop (tanto il tempo di boot è rapido).

  17. Cristian scrive:

    Davvero nno capisco ‘sta moda di usare tutti Ubuntu ed i suoi derivati. A me, che ho usato Ubuntu sia 4 che 5, pare solo una simil-Debian, con tutti i difetti tipici delle Debian (apt non architeturizzato per i 64bit, fonts ignobilmente piccoli ed illeggibili nelle applicazioni GTK1, enorme instabilita’ delle applicazioni piu’ recenti eccetera…) ma con un look & feel piu’ “figo”.

    Personalmente, dovendoci lavorare, io prendo in considerazione SOLO le Fedora Core come desktop e le CentOS (o Redhat 9, in caso si voglia spendere qualche centinaio di euri) per i server. Non riesco a vedere altre soluzioni pratiche, sinceramente.

  18. dalco scrive:

    Cristian, potrei dire le stesse cose di Fedora (e il suo disastroso updater online), e cose ancor peggiori di Redhad 9 (soprattutto sul gestore pacchetti che non riesce, manco fosse Torvalds a chiederglielo, a tener traccia delle dipendenze e a non “romperle”).

    Potrei anche consigliarti OpenSuse lato Desktop, dato che, dovendoci lavorare, non vedo altre alternative. Analogamente lato server per Intranet non vedo alternative a SME Server, e per server che stanno in internet non vedo alternative a Debian.

    Ma non lo faccio, perché ognuno si fa le ossa su di una distribuzione, che poi gli diventa magicamente meno ostile delle altre e riesce a fargli fare qualunque cosa (incluso il caffè).

  19. dalco scrive:

    Uh, PT, mi sbagliavo: il log da controllare per le procedure di boot/shutdown è /var/log/boot.msg

    Prova a tenerne traccia nel modo che ti ho indicato sopra!

  20. flod scrive:

    In *ubuntu credo sia var/log/boot.
    Dopo aver lanciato lo shutdown non vedo assolutamente nulla nell’altro terminale (quello dove è in esecuzione tail).

  21. flod scrive:

    Altra discussione
    http://forum.parallels.com/showthread.php?t=5320&highlight=ubuntu+shut

    Ora che me lo fan notare nemmeno io vedo lo splash screen durante il boot 😕

  22. Luigi Molinaro scrive:

    Per la splashscreen è un problema di grub, per risolvere vai ad editare dentro /boot/grub/ il file menu.lst.
    Edita la chiamata al kernel ed aggiungi alla gine vga=791 e ti parte la splash a 1024.×768 altrimenti prova vga=788 per un 800×600 CIao !

  23. Sobo scrive:

    Ho usato Parallels Desktop 1970 su iMac e su Mac Book Pro. Su iMac non mi ha dato problemi mentre su Mac Book Pro sono riouscito dapprima ad installare Windows Xp senza problemi e anche Kubuntu ma da quando ho provato con Suse non riesco più ad installare nè kubuntu nè ubuntu nè suse nè mandriva nè debian insomma la VM si blocca poco dopo l’inizio dell’installazione la schermata resta nera e non va più avanti. La prima volta ho risolto il problema d’isinstallando Parallels e reinstallandolo ma poi il problema è uscito di nuovo.
    Qualcuno sa qualcosa???

  24. flod scrive:

    Già provato a cancellare le preferenze di Parallels? In ogni caso ti consiglio di provare a chiedere sul forum di Tevac 😉

Trackback e pingback

  1. Nessun trackback o pingback disponibile per questo articolo

Non è possibile inserire nuovi commenti. I commenti vengono disattivati automaticamente dopo 60 giorni.